Yes, Flash sucks. But many of us need it for one site or another. And lots of us are running 64-bit Linux these days, where Adobe has famously refused (so far) to update the plugin for the recent serious vulnerabilities in Flash, leaving us between a rock and a hard place. Just a quick reminder - the bad old way of doing things still works...that is, nspluginwrapper. First, get a copy of the Flash plugin from the Adobe web site. Don't use the yum repo, as it pulls in Adobe Reader as a dependency of Flash (classy move, Adobe) which will result in even more 32-bit crap getting installed on your system than necessary. Just get the .tar.gz, and extract it into /usr/lib/mozilla/plugins (not /usr/lib64). Now do: yum install nspluginwrapper.i686 (you'll also need to install the x86-64 package, for most people it should be installed already, but check - thanks Hansvon!) and it should do its stuff. Remove gnash if you installed it, then restart Firefox, and you should be good to go. If not, use about:plugins in Firefox, and mozilla-plugin-config (useful parameters - -l, -v) at the console as root to diagnose.