Poulsbo update: kernel 2.6.30 support

Kernel 2.6.30 went into updates-testing for Fedora 11 today, so I decided to test the Poulsbo stuff with it. Not at all surprisingly, the module doesn’t build out of the box with 2.6.30, it hits two failures. One of them I fixed myself, for the other I am eternally grateful to the wonderful Chuck Ebbert and Dave Airlie for rendering the fix. The updated akmod-psb package you’ll need for kernel 2.6.30 when it hits is now in my repository, version 4.41.1-4. Once you have that installed, when kernel 2.6.30 hits stable updates, your graphics should hopefully keep right on truckin’.

10 Responses

  1. joebie
    joebie August 18, 2009 at 11:19 am | | Reply

    First of all I have tried the new 2.6.30 kernel from the testing repository it breaks with a backtrace right after or during loading of the psb module. I also tried an older 2.6.29 kernel which worked just as expected. What would be the most helpful thing to do? Where should I post the backtrace and or debug output. Second I have tried KDE it worked fine without desktop effects but I had to force the font/monitor DPI to 96 to get a normal font size.

  2. joebie
    joebie August 19, 2009 at 2:45 am | | Reply

    It does look like it, but I’m not able to find a log file with the error.
    The message goes something like:


    last sysfs file: /sys/devices/pci0000:00/0000:00:02.0/loading
    Modules linked in: … psb(+) … drm …

    Process modprobe …

    Call Trace:
    [addr] ? snprintf …
    [addr] ? drm_sysfs_device_add+0x4b/0xa3 [drm]
    [addr] ? drm_get_dev+0x3fc/0x51c [drm]

    Does this help or should I go looking for a way to save the error to file.

  3. joebie
    joebie August 19, 2009 at 8:08 am | | Reply

    Let me know when or if I should do something.

  4. joebie
    joebie August 20, 2009 at 12:09 am | | Reply

    Just tested the new package. After removing the old generated kmod and doing a restart, it now works. Thanks!

  5. reiv
    reiv August 25, 2009 at 6:40 am | | Reply

    Thank you for the update. My Gentoo system works as good as before with 2.6.30(tuxonice) kernel(just keep other package untouched), and mplayer hw decoding also works, but there’s a problem with “psb_dri.so” from “xpsb-glx-0.18-4.fc11.i686.rpm”(I use old one to get GMA500 work). I think it because my xorg-server-1.4.2 is too old. Adamw, would please you tell me what’s your xorg-server and mesa version ? And, it’s hard to install any newer xserver than 1.4.2 with libdrm-poulsbo-2.3.0 on Gentoo, because any xserver-1.5.x or higher depend on mesa version 7.1 or higher , and any mesa-7.1 or higher depend on libdrm-2.3.1 or higher, but there’s only 2.3.0 version of libdrm.

  6. reiv
    reiv August 26, 2009 at 5:46 am | | Reply

    thank you, now I successful upgrade to X server 1.5.3.

You can comment without reCAPTCHA by using an OpenID as the URL, or logging in with an OpenID or an old site account.

Leave a Reply